Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2024 - 12:00 UTC
Scheduled
A planned software release will take place between Sept 9th and Sept 24th on all Podcast Delivery instances (Mediacasters).
This update introduces the following features and improvements: - Bug fixes
Although there are no critical bug fixes, we consider the timing adequate before the bulk of the "ad season" in Oct-Dec.
Podcasting service will not be affected. Our teams unload the traffic from each software instances before doing an update and re-starting the instance.
Our team will be monitoring the situation closely throughout the scheduled maintenance. If you have any questions or concerns, please feel free to reach out by opening up a ticket via our Support portal: http://support.tritondigital.com/.
Best Regards, Your Triton Digital Team
Posted Sep 03, 2024 - 21:10 UTC
This scheduled maintenance affected: EMEA (Podcast Delivery), AMERICAS (Podcast Delivery), and APAC (Podcast Delivery).