Manadge (TAP Programmatic Analytics Dashboard) - Deals with start date on or after 06/01 are not displayed

Incident Report for Triton Digital Platform Status

Resolved

The team has implemented the fix and the deals are now being displayed in Manadge. We consider the incident as resolved.
Posted Jun 02, 2026 - 15:33 UTC

Investigating

We are currently investigating an issue where deals with the start date on or after 06/01 are not displayed in Manadge (TAP Programmatic Analytics Dashboard). This is only impacting Manadge reporting platform.
Bid requests are being sent and most of the deals seem to have already started delivering.
More information to come.
Posted Jun 02, 2026 - 09:16 UTC
This incident affected: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).