Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 25, 2026 - 15:45 UTC
Scheduled
A software maintenance and feature update will take place on 2026-02-25 at 03:45 PM UTC. This update includes the following improvements to the Triton User Management Console:
* Resolved an issue where the Create button remained disabled even when all required fields were properly completed during new user creation.
* Corrected the progress indicator so that the User Details section is properly marked as completed once all required fields are valid.
* Added a visual loading indicator (spinner) in the Content Access section to clearly show when data is being loaded before display.
The following component will be updated:
* Triton User Management Console.
There is no expected downtime or service interruptions for the Triton User Management UI.
If you have any questions, please contact us by submitting a Support ticket.
Best Regards, Your Triton Digital Team
Posted Feb 25, 2026 - 14:57 UTC
This scheduled maintenance affected: EMEA (Settings UI), AMERICAS (Settings UI), and APAC (Settings UI).