Slower response times for On Demand ad requests (Montreal and Ashburn locations only)

Incident Report for Triton Digital Platform Status

Resolved

The source of the latency has been found and corrections have been applied. On Demand response times are now back to normal operating parameters.
This incident is considered resolved.
Posted Jul 11, 2025 - 19:49 UTC

Investigating

We are investigating an issue where we are seeing higher than normal latency responses from our On Demand ad service.
The issue seems to be contained to our Ashburn and Montreal locations.
More information to come.
Posted Jul 10, 2025 - 20:58 UTC
This incident affected: AMERICAS (On-Demand Ad Delivery).