Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 15:30 UTC
Scheduled
A software maintenance & deployment of a bug fix will take place on 2026-05-20 at 3 PM UTC. This update introduces the following changes:
* Fixed an issue where Demo + data for the Netherlands was not working as expected due to a filter update involving “Netherlands” and “The Netherlands.”
* Fixed some publisher-specific Metrics API queries impacted by the use of the “Netherlands” versus “The Netherlands” filter.
* Reinforce 24-hour sessions duration in Metrics UI.
Please note that there is no expected downtime for Metrics UI, and you should not experience any service interruptions during this process.
If you have any questions, please contact us by creating a Support ticket.
Best Regards, Your Triton Digital Team
Posted May 20, 2026 - 15:01 UTC
This scheduled maintenance affected: EMEA (Metrics API (Advertising + Measurement), Podcast Metrics UI), AMERICAS (Metrics API (Advertising + Measurement), Podcast Metrics UI), and APAC (Metrics API (Advertising + Measurement), Podcast Metrics UI).