Delays in Podcast Advertising
Incident Report for Triton Digital Platform Status
Resolved
This issue is considered resolved.
Posted Jan 26, 2022 - 16:13 UTC
Monitoring
Our teams have identified the issue and have issued a fix for this issue. We are monitoring the situation.
Posted Jan 06, 2022 - 19:34 UTC
Investigating
We are investigating an issue where an ad request for a Podcast can be delayed for requests in North America. Our team is already working upon a resolution, more information will follow.
Posted Jan 06, 2022 - 19:20 UTC
This incident affected: AMERICAS (Podcast Ad Delivery).