Omny Studio API/UI - Intermittent errors and slow performance

Incident Report for Triton Digital Platform Status

Update

The issue prevailed from around 12-17 UTC.
It also affected Time To Listen for listeners, which increased by a few seconds.
We are continuing to monitor the situation.
Posted Nov 25, 2025 - 17:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 17:39 UTC

Investigating

We are investigating an issue impacting Omny Studio API and UI services. Some of our users can experience slowness and intermittent errors while navigating through the API/UI.
Podcast RRS and episodes delivery are not being impacted.
More information to come.
Posted Nov 25, 2025 - 15:45 UTC
This incident affects: EMEA (Omny Studio Management Portal, Omny Studio Management API), APAC (Omny Studio Management Portal, Omny Studio Management API), and AMERICAS (Omny Studio Management Portal, Omny Studio Management API).