Mitigation measures have been applied to existing stations that were no longer authenticating due to case sensitivity mismatches Station Keys. We advise our clients to consider reviewing their station keys according to their security policies. This incident is considered resolved.
Posted Mar 31, 2026 - 16:35 UTC
Identified
As a result fo the Settings UI Maintenance that happened earlier today (https://tritonstatus.statuspage.io/incidents/tmbfgtrspjyz), Station Passwords (now called Station Keys) are now required to be case sensitive (as seen in the Common Assets UI). Any password having been previously entered in Station Manager with the wrong case (upper case / lower case) will need to be re-entered with the exact case as see in the new Common Assets UI. In such cases, stations may stop streaming if the password was not correctly input in Station Manager. Please consult our guide for accessing the Common Assets UI in Settings and managing your Station Keys: https://help.tritondigital.com/docs/radio-stations For any issues, please contact support at supportdesk@tritondigtial.com
Posted Mar 30, 2026 - 19:29 UTC
This incident affected: AMERICAS (Live Streaming Delivery - East, Live Streaming Delivery - West), EMEA (Live Streaming Delivery), and APAC (Live Streaming Delivery - South East & Pacific).