TAP - Ondemand ad delivery performance degradation

Incident Report for Triton Digital Platform Status

Monitoring

Mitigation measures have been applied by the third party platform. The volume of requests has returned to normal operating parameters.
While we do not expect further issues, we will monitor the situation closely for the time being.
More information to come.
Posted Aug 25, 2026 - 20:59 UTC

Identified

We have identified the cause of the issue to be an abnormally high volume of requests coming from a third party platform. We have put mitigation measures in place to restrict traffic from this platform and are engaging with them to remediate the situation.
More information to come.
Posted Aug 25, 2026 - 16:07 UTC

Update

We are currently investigating reports of a temporary decrease in ad selection and delivery impacting On-Demand direct sold and programmatic campaigns.
Ad request processing remains operational, but some publishers may experience lower than expected fill rates or delivery pacing.
More information to come
Posted Aug 25, 2026 - 15:43 UTC

Investigating

We are currently investing an issue impacting ondemand ad delivery.
More information to come.
Posted Aug 25, 2026 - 13:34 UTC
This incident affects: EMEA (Programmatic Ad Delivery, On-Demand Ad Delivery), AMERICAS (Programmatic Ad Delivery, On-Demand Ad Delivery), and APAC (Programmatic Ad Delivery, On-Demand Ad Delivery).