Issue with Impressions Delivered counts populating in TAP UI

Incident Report for Triton Digital Platform Status

Resolved

This incident is now considered resolved.
Posted May 05, 2026 - 14:04 UTC

Monitoring

We are currently monitoring an issue where users might have experienced momentarily where impression data was not displayed in campaign/flight tables in TAP UI. This was not impacting delivery.
Posted May 04, 2026 - 15:48 UTC
This incident affected: EMEA (TAP UI), AMERICAS (TAP UI), and APAC (TAP UI).