TAP Programmatic Global Exclusion Rules issue

Incident Report for Triton Digital Platform Status

Resolved

This incident is considered resolved.
Posted Jul 15, 2025 - 14:01 UTC

Monitoring

A fix was applied and the UI is now back to being accessible.
We are monitoring the results closely.
Posted Jul 11, 2025 - 19:43 UTC

Update

The cause of the issue has been found. In order to minimize potential negative impacts on ad delivery, access to TAP Settings -> Programmatic has been suspended.
More information to come.
Posted Jul 11, 2025 - 18:22 UTC

Investigating

We currently have an issue with creation and update of Global Exclusion Rules in TAP Programmatic.
Please refrain from creating or modifying global exclusion rules for the duration of this incident.
Ad delivery and previously created rules are not affected.
More information to come.
Posted Jul 11, 2025 - 16:36 UTC
This incident affected: AMERICAS (TAP Programmatic UI (Yield-Op)), APAC (TAP Programmatic UI (Yield-Op)), and EMEA (TAP Programmatic UI (Yield-Op)).