Omny Studio unreachable

Incident Report for Triton Digital Platform Status

Resolved

No further signs of issues have been observed.
This incident is considered resolved.
Posted Mar 28, 2025 - 14:41 UTC

Monitoring

Omny Studio experienced an issue where it was temporarily unreachable from 16:00 to 16:20 UTC.
Our team is investigating the cause and monitoring the situation closely.
Posted Mar 24, 2025 - 18:30 UTC
This incident affected: EMEA (Omny Studio Management Portal), AMERICAS (Omny Studio Management Portal), and APAC (Omny Studio Management Portal).