TAP Programmatic - Delay in deal synchronization

Incident Report for Triton Digital Platform Status

Monitoring

Mitigation measures have been applied and all deals that were previously stuck have been synchronized successfully.
Should you encounter any further anomaly with a particular deal, please email our support team at supportdesk@tritondigtial.clom for assistance.
We will be monitoring the situation closely.
Posted Mar 20, 2026 - 00:25 UTC

Investigating

As a result of the TAP Programmatic UI - Intermittent errors incident experienced on March 19th, we are experiencing a delay in synchronisation for deals having been created March 18th and March 19th. The system is working through deal synchronizations but the process is taking much longer than usual.
Our development team is working to add mitigation measures to help the system work faster through the backlog of deals to be synched.
More information to come.
Posted Mar 20, 2026 - 00:03 UTC
This incident affects: EMEA (Programmatic Ad Delivery, TAP Programmatic UI (Yield-Op)), AMERICAS (Programmatic Ad Delivery, TAP Programmatic UI (Yield-Op)), and APAC (Programmatic Ad Delivery, TAP Programmatic UI (Yield-Op)).