Planned Maintenance – Triton Ad Platform (UI & Ads Endpoint) - March 23th

Scheduled for Mar 23, 18:00 - 19:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 19, 2026 - 13:58 UTC

Scheduled

Impact:
During this maintenance window, access to the Triton Ad Platform UI and related ad delivery endpoints may be briefly unavailable or experience intermittent issues while we complete the migration.

Details:
The TAP-UI team will be performing planned maintenance to migrate the Triton Ad Platform UI and associated infrastructure to GitHub and a new AWS/S3/CloudFront setup. This change is intended to improve reliability, performance, and maintainability of the platform.

We do not expect a prolonged outage, but short periods of downtime or degraded performance may occur during the cutover and DNS updates.

User Action:
No action is required from customers. If you experience issues beyond the maintenance window, please contact Triton Support.
Posted Mar 19, 2026 - 13:52 UTC
This scheduled maintenance affects: EMEA (TAP UI), AMERICAS (TAP UI), and APAC (TAP UI).