Podcast metrics data delay

Incident Report for Triton Digital Platform Status

Resolved

All data has been processed and is displaying normally under expected data delays.
This incidente is considered resolved.
Posted May 07, 2025 - 19:07 UTC

Identified

We have identified an issue with our data processing mechanisms which is causing a delay in our podcast metrics data. Data is about 90 minutes behind at the moment. We are actively working on increasing processing capabilities to mitigate the issue. We are hopeful to have the system back to normal in approximately 4-5 hours.
More information to come.
Posted May 07, 2025 - 13:21 UTC
This incident affected: EMEA (Podcast Metrics UI), AMERICAS (Podcast Metrics UI), and APAC (Podcast Metrics UI).