Data delay in Manadge for May 15th

Incident Report for Triton Digital Platform Status

Resolved

The data pipeline was restored. Missing data has been reprocessed and is now available in the Manadge.
Data is now flowing normally.
This incident is considered resolved.
Posted May 15, 2026 - 21:39 UTC

Investigating

We are currently investigating a data processing issue resulting in data being late in Manadge. Users will see no data since 12:00 (noon) UTC.
More information to follow.
Posted May 15, 2026 - 19:59 UTC
This incident affected: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).