Omny analytics delayed for some organizations

Incident Report for Triton Digital Platform Status

Resolved

Processing has caught up and data is now up to date in the UI. Data mechanisms are operating normally.
This incident is considered resolved.
Posted Mar 18, 2026 - 00:10 UTC

Identified

A fix was applied to the data processing mechanisms. Data is currently starting to populate and catch up in the UI.
More information to come.
Posted Mar 17, 2026 - 22:12 UTC

Investigating

We are investigating an issue causing delays in Omny analytics to display for some organizations. The issue is known to affect data from 2026-03-17 07:00 UTC onwards. This incident does not affect Podcast Metrics data. More information to come.
Posted Mar 17, 2026 - 20:45 UTC
This incident affected: EMEA (Omny Studio Management Portal), APAC (Omny Studio Management Portal), and AMERICAS (Omny Studio Management Portal).