Ad delivery - High latency reponse time

Incident Report for Triton Digital Platform Status

Update

A fix has been implemented and we are monitoring the situation
Posted Aug 14, 2026 - 17:45 UTC

Monitoring

This incident has been resolved and we are continuing to monitor.
Posted Aug 14, 2026 - 17:40 UTC

Investigating

We are aware of an issue affecting the performance of our Advertising Services, which may result in delayed responses or, in some cases, failed requests.
Our team is actively investigating the issue and working to identify the root cause.
We will provide further updates as more information becomes available.
Posted Aug 14, 2026 - 15:33 UTC
This incident affects: EMEA (Live Streaming Ad Delivery, Podcast Ad Delivery, Programmatic Ad Delivery, On-Demand Ad Delivery), AMERICAS (Live Streaming Ad Delivery, Podcast Ad Delivery, Programmatic Ad Delivery, On-Demand Ad Delivery), and APAC (Live Streaming Ad Delivery, Podcast Ad Delivery, Programmatic Ad Delivery, On-Demand Ad Delivery).