Metrics UI not displaying Total Measurement for some users (intermittent)

Incident Report for Triton Digital Platform Status

Resolved

This incident is considered resolved.
Posted Oct 28, 2025 - 19:06 UTC

Monitoring

The cause fo the issue was found and a fix was applied a moment ago. Users should now be seeing the Total Measurement sub section consistently if they have been granted access to it.
We will be monitoring the situation closely.
Posted Oct 28, 2025 - 14:55 UTC

Investigating

We are investigating an issue with the Metrics UI where some users are not being shown the Total Measurements sub sections of the Metrics UI.
Users are instructed to log out, close their browsers and try again as this issue seems to be intermittent.
More information to come.
Posted Oct 27, 2025 - 17:20 UTC
This incident affected: EMEA (Webcast Metrics UI), AMERICAS (Webcast Metrics UI), and APAC (Webcast Metrics UI).