Manadge (TAP Programmatic Analytics Dashboard) - Deal ID not available as a filter

Incident Report for Triton Digital Platform Status

Identified

We have identified the cause of the issue and our team is working on developing a fix.
More information to come.
Posted Aug 26, 2026 - 19:28 UTC

Update

Our team continues to investigate the cause of the issue, which is proving to be more challenging to locate than previously anticipated.
More information to come.
Posted Aug 25, 2026 - 17:43 UTC

Investigating

We are currently investigating an issue impacting Manadge (TAP Programmatic Analytics Dashboard). The Deal ID is not available as a filter. This can disrupt Dashboard already created that were filtered by Deal ID.
More information to come.
Posted Aug 21, 2026 - 14:56 UTC
This incident affects: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).