Issue with DMP segments loading in TAP UI Listener targeting

Incident Report for Triton Digital Platform Status

Investigating

We are currently investigating an issue where the list of DMP segments is not loading in the TAP UI Listener targeting section. This is not affecting delivery of flights that have existing DMP segments already selected.
Posted Apr 29, 2026 - 14:08 UTC
This incident affects: EMEA (TAP UI), AMERICAS (TAP UI), and APAC (TAP UI).