Omny UI unresponsive

Incident Report for Triton Digital Platform Status

Resolved

Microsoft Azure has remained stable and no further effects of their outage has been observed on the Omny platform ad services.
This incident is considered resolved.
Posted Jul 24, 2026 - 18:15 UTC

Monitoring

Microsoft identified the issue to a deployment that they recently made. They have rolled back that deployment and service has now returned to normal.
Omny services are now available for client use and operating under normal conditions.
We will monitor the situation closely.
Posted Jul 23, 2026 - 19:07 UTC

Update

Microsoft are continuing their efforts to identify the root cause of their issue. We are actively following their efforts.
More information to come.
Posted Jul 23, 2026 - 18:08 UTC

Identified

Azure (Microsoft) have confirmed that this incident is a result of a major networking issue that they are experiencing in the Western USA.
We are attempting to mitigate the impact of their issues and are following their progress in resolving their issues.
More information to come.
Posted Jul 23, 2026 - 16:55 UTC

Update

The issue has been confirmed to also affect to the Omny Management API as well as other Omny APIs, Omny Recording Agent, Omny.fm and Omny players in addition to the Omny management portal.
Our team has determined the issue relies with an Azure component. We are in contact with Azure support to resolve the issue.
More information to come.
Posted Jul 23, 2026 - 16:39 UTC

Investigating

We are investigating an issue with the Omny UI where users are presented with a Server Error when trying to access Omny.
More information to come.
Posted Jul 23, 2026 - 15:34 UTC
This incident affected: EMEA (Omny Studio Management Portal, Omny Studio Management API, Omny Studio Recording Agent, Omny Studio Webhooks Service, Omny.fm Publishing), APAC (Omny Studio Management Portal, Omny Studio Management API, Omny Studio Recording Agent, Omny Studio Webhooks Service, Omny.fm Publishing), and AMERICAS (Omny Studio Management Portal, Omny Studio Management API, Omny Studio Recording Agent, Omny Studio Webhooks Service, Omny.fm Publishing).