TAP UI Error when adding DMP Segments to a flight

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been deployed and DMP Segments are once again viewable and usable in TAP UI.
We will be monitoring the situation closely.
Posted Apr 09, 2026 - 21:25 UTC

Identified

We have identified the cause of the issue and are working on a fix.
Please note that this incident is not affecting ad delivery.
More information to come.
Posted Apr 09, 2026 - 20:07 UTC

Investigating

We are investigating an issue where users will be presented with an error when trying to add DMP Segments to a flight.
More information to come.
Posted Apr 09, 2026 - 20:04 UTC
This incident affects: EMEA (TAP UI), AMERICAS (TAP UI), and APAC (TAP UI).