Errors trying to load Omny services or play audio

Incident Report for Triton Digital Platform Status

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 20:19 UTC

Monitoring

Omny services have returned to normal. Recording agents are now back to operating normally.
Cloudflare’s incident is still open and so we will continue to monitor their progress.
More information to come.
Posted Nov 18, 2025 - 17:31 UTC

Update

Service has been restored to the Omny CSM as well as Omny.fm.
We continue to work on restoring recording agent services following the Cloudflare issues.
Cloudflare's incident is still open and so there may be future service interruptions as they work through their issues.
More information to come.
Posted Nov 18, 2025 - 16:23 UTC

Identified

Our partner Cloudflare are continuing to work through their outage. More information can be found by visiting their status page: https://www.cloudflarestatus.com
Access to Omny and Omny.fm is unreliable at the moment as they continue to work through their issues.
More information to come.
Posted Nov 18, 2025 - 14:14 UTC

Investigating

We are aware of an issue with a third party service provider that is impacting access to all Omny services, including the CMS UI, omny.fm and audio playback. We are monitoring closely and further details will be provider as they become available
Posted Nov 18, 2025 - 12:05 UTC
This incident affects: EMEA (Omny Studio Management Portal, Omny Studio Management API, Omny.fm Publishing), APAC (Omny Studio Management Portal, Omny Studio Management API, Omny.fm Publishing), and AMERICAS (Omny Studio Management Portal, Omny Studio Management API, Omny.fm Publishing).