Triton Digital's SSP unable to sync new deals with The Trade Desk

Incident Report for Triton Digital Platform Status

Resolved

A fix was applied to our synchronization mechanism with The Trade Desk. Deals are once again sycning normally. All deals created during the incident have now properly synced to The Trade Desk.
This incident is considered resolved.
Posted Aug 24, 2026 - 16:48 UTC

Identified

We have identified a problem with our deal synchronisation mechanism with The Trade Desk. Deals created since August 20th are not syncing with The Trade Desk and therefore will not become active for delivery. We have contacted the DSP and are awaiting new authorization.
Existing deals are unaffected.
More information to come.
Posted Aug 21, 2026 - 20:36 UTC
This incident affected: EMEA (Live Streaming Ad Delivery), AMERICAS (Programmatic Ad Delivery), and APAC (Programmatic Ad Delivery).