Podcast time based Frequency Capping

Incident Report for Triton Digital Platform Status

Resolved

This incident is considered resolved.
Posted Nov 04, 2025 - 15:41 UTC

Monitoring

Our team has applied a fix. Time-based frequency capping (hour/day/week/lifetime) should now be properly applied for podcast ad delivery.
We are closely monitoring the situation.
Posted Oct 28, 2025 - 19:08 UTC

Identified

We have identified a bug affecting podcast ad delivery that prevents time-based frequency capping (hour/day/week/lifetime) from being correctly applied. As a result, some listeners may have received the same ad more times than intended.
Our team has investigated the issue and is actively deploying a fix. Once resolved, time-based capping will work as expected for podcast campaigns. We appreciate your patience.
More information to come.
Posted Oct 27, 2025 - 13:16 UTC

Investigating

We are currently investigating an issue affecting time-based frequency capping (hour/day/week/lifetime) for podcast ad delivery. Some flights may not be enforcing these caps as expected.
Our team is actively working to identify the root cause and will provide further updates as soon as more information is available.
More information to come.
Posted Oct 24, 2025 - 15:25 UTC
This incident affected: EMEA (Podcast Ad Delivery), AMERICAS (Podcast Ad Delivery), and APAC (Podcast Ad Delivery).