Manadge (TAP Programmatic Dashboard)- Deal Name in lowercase

Incident Report for Triton Digital Platform Status

Identified

We have identified the issue and are actively working on a permanent solution
The deals that were created since Feb11th have been fixed. 
However, any new deals created will still be in lowercase and the fix is planned for early next week.
More information to come.
Posted Feb 26, 2026 - 17:06 UTC

Investigating

We are currently investigating an issue impacting all deals created after February 11th, where the deal name is all in lowercase.
More information to come
Posted Feb 26, 2026 - 13:58 UTC
This incident affects: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).