Unable to log into the Manadge UI

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been applied. Manadge UI is once again allowing users to log in and is displaying data properly.
We are monitoring the situation closely.
Posted Apr 16, 2026 - 21:47 UTC

Investigating

We are investigating an issue preventing users from logging into the Manadge UI. Our team is actively working on a solution.
Note that this incident is not affecting programmatic ad delivery.
More information come.
Posted Apr 16, 2026 - 20:56 UTC
This incident affects: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).