LDN Datacenter - Network instability

Incident Report for Triton Digital Platform Status

Resolved

Connectivity and services have now been fully restored to our London data centre.
This incident is considered resolved.
Posted May 06, 2026 - 17:22 UTC

Identified

The issue was identified to be a faulty network equipment. The equipment was replaced and our team is currently working on restoring connectivity and services to the data centre.
More information to come.
Posted May 06, 2026 - 17:06 UTC

Investigating

We are currently investigating a network instability affecting our London datacenter.
Listener experience and ad delivery might be impacted.
We will provide further updates as more information becomes available.
Thank you for your patience.
Posted May 06, 2026 - 07:07 UTC
This incident affected: EMEA (Live Streaming Delivery, Podcast Delivery, Live Streaming Ad Delivery, Podcast Ad Delivery, On-Demand Ad Delivery).