Metrics UI - Login errors to Webcast Metrics Podcast Metrics and TAP Explore

Incident Report for Triton Digital Platform Status

Monitoring

The issue was found to be an unexpected side effect of a deployment made as part of the recent Metrics UI maintenance for 2026-05-05 at 07:30 PM UTC (https://tritonstatus.statuspage.io/incidents/p18m3qp182hm). A rollback has been applied which has restored functionality. Users still seeing a blank page are instructed to clear their browser cache and log back into Metrics/Tap.
We are monitoring the situation closely.
Posted May 08, 2026 - 15:23 UTC

Investigating

We are currently investigating reports of some users having issues accessing to Metrics UI (Webcast Metrics, Podcast Metrics and TAP Explore).
As a workaround we recommend clearing your browser cache and temporary files and/or use incognito/Private mode.
More information to come.
Posted May 08, 2026 - 08:29 UTC
This incident affects: EMEA (TAP Explore, Podcast Metrics UI, Webcast Metrics UI), AMERICAS (TAP Explore, Podcast Metrics UI, Webcast Metrics UI), and APAC (TAP Explore, Podcast Metrics UI, Webcast Metrics UI).