Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2026 - 18:00 UTC
Scheduled
A software maintenance & deployment of a new feature will take place on 2026-08-24 at 6 PM UTC. This update introduces the following changes:
* The Podcast Video report in Metrics UI will be expanded to include Engaged Views metric for YouTube API clients. This enhancement will allow clients to compare Views with Engaged Views directly within the report. Both metrics are based on data provided through the YouTube Analytics and Reporting API.
The following components will be updated: * Podcast Metrics UI
If you have any questions, please contact us by creating a Support ticket.
Best Regards, Your Triton Digital Team
Posted Aug 24, 2026 - 13:05 UTC
This scheduled maintenance affected: EMEA (Podcast Metrics UI), AMERICAS (Podcast Metrics UI), and APAC (Podcast Metrics UI).