Issue with Lagging/Timeout selecting Content Access Control in User Management UI.

Incident Report for Triton Digital Platform Status

Resolved

This issue has been resolved.
Posted Jul 02, 2026 - 16:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 18:23 UTC

Investigating

We are currently investigating an issue impacting the User Management UI when opening the Content Access section, where some requests may experience increased latency or occasional timeouts..  More information to follow.
Posted Jun 30, 2026 - 17:14 UTC
This incident affected: EMEA (Settings UI), AMERICAS (Settings UI), and APAC (Settings UI).