Slowness when uploading new clips

Incident Report for Triton Digital Platform Status

Resolved

The system is stable and we are no longer seeing issues with the upload mechanism.
This incident is considered resolved.
Posted Jun 11, 2026 - 18:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2026 - 07:01 UTC

Investigating

We are currently investigating reports of slowness when uploading new clips to the Omny platform. More information will follow.
Posted Jun 10, 2026 - 15:49 UTC
This incident affected: EMEA (Omny Studio Management Portal), APAC (Omny Studio Management Portal), and AMERICAS (Omny Studio Management Portal).