Manadge UI unreachable

Incident Report for Triton Digital Platform Status

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 06:32 UTC

Monitoring

A fix has been applied. Manadge is once again reachable. Data will also be returned from the Manadge API.
We will be monitoring the situation closely.
Posted Jun 01, 2026 - 02:25 UTC

Investigating

We are currently investigating an issue where users are unable to access (login) Manadge.
The issue is also preventing the Manadge API from returning data.
Note that this incident does not affect programmatic ad delivery.
More information to come.
Posted May 31, 2026 - 23:57 UTC
This incident affected: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).