Now Playing (Song History) Service API unavailable

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been applied and the API is now returning data as normal.
We are actively monitoring the situation.
More information to come.
Posted Aug 10, 2026 - 15:41 UTC

Investigating

We are investigating an issue with the Now Playing (or "Song History") service API where no songs are returned when a query is made. This may impact certain players using this API to display currently playing songs and also players using the API to display past songs.
Live song information via cue points are not affected by this incident.
More information to come.
Posted Aug 10, 2026 - 13:59 UTC
This incident affects: AMERICAS (Live Streaming Delivery - East, Live Streaming Delivery - West), EMEA (Live Streaming Delivery), and APAC (Live Streaming Delivery - South East & Pacific).