TAP Explore - Selecting Segment PoP results in blanc page

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been deployed. Users should now see TAP Explore behave normally.
We will be monitoring the situation closely.
Posted May 08, 2026 - 21:16 UTC

Identified

The origin of the issue was identified. Our team is working on a fix.
More information to come.
Posted May 08, 2026 - 19:20 UTC

Investigating

We are investigating an issue in TAP Explore where users selecting the "Segment PoP" Report Type will cause the UI to go blanc.
Our team is actively looking on restoring functionality.
More information to come.
Posted May 08, 2026 - 19:05 UTC
This incident affects: EMEA (TAP Explore), AMERICAS (TAP Explore), and APAC (TAP Explore).