Missing data on November 19th in TAP Explore (Creatives, Sell-Thru-Rate and Sweepers)

Incident Report for Triton Digital Platform Status

Resolved

This issue is considered resolved.
Posted Nov 21, 2025 - 23:44 UTC

Monitoring

Data is now available for November 19th. Data availability is now back to normal
We will be monitoring the situation closely.
Posted Nov 21, 2025 - 23:44 UTC

Investigating

We are currently investigating missing data for Nov 19th in TAP Explore for the following report types:
- Creatives
- Sell-Thru-Rate
- Sweepers
More information to come.
Posted Nov 21, 2025 - 19:08 UTC
This incident affected: EMEA (TAP Explore), AMERICAS (TAP Explore), and APAC (TAP Explore).