Manadge (TAP Programmatic Dashboard) - Reduced auction count for some publishers

Incident Report for Triton Digital Platform Status

Resolved

This incident is now resolved. We have rolled out a fix which addresses the issue going forward. Please note that clients may see reduced auction counts for 12-18 March ET (inclusive) for any auctions where there were no bids.
Posted Mar 19, 2026 - 09:06 UTC

Identified

We are investigating an issue whereby some publishers are seeing reduced auction counts in their Manadge (TAP Programmatic Dashboard) dashboards.

We have identified and are working on a solution which will fix the issue for data going forward.

More information to come.
Posted Mar 19, 2026 - 09:06 UTC
This incident affected: AMERICAS (Manadge (TAP Programmatic Analytics Dashboard)), APAC (Manadge (TAP Programmatic Analytics Dashboard)), and EMEA (Manadge (TAP Programmatic Analytics Dashboard)).